Cấu hình OSPF

Yêu cầu:
– Cấu hình định tuyến OSPF theo hình mô tả
– R8 cấu hình static routing ping thông toàn bộ mạng trong vùng OSPF

Thực hiện:
– R3, R5 (tương tự):
(config)#interface loopback 0
(config-if)#ip address 3.3.3.3 255.255.255.255
(config-if)#interface g0/0
(config-if)#no shut
(config-if)#ip address 192.168.234.3 255.255.255.0
(config)#router ospf 1
(config-router)#network 3.3.3.3 0.0.0.0 area 2
(config-router)#network 192.168.234.0 0.0.0.255 area 2

– R2, R4 (tương tự):
(config)#interface loopback 0
(config-if)#ip address 2.2.2.2 255.255.255.255
(config-if)#interface g0/1
(config-if)#no shut
(config-if)#ip address 192.168.234.2 255.255.255.0
(config-if)#ip ospf priority 255
(config-if)#interface g0/0
(config-if)#no shut
(config-if)#ip address 192.168.12.2 255.255.255.0
(config)#router ospf 1
(config-router)#network 2.2.2.2 0.0.0.0 area 0
(config-router)#network 192.168.12.2 0.0.0.255 area 0
(config-router)#network 192.168.234.0 0.0.0.255 area 2

Lệnh reset tiến trình OSPF khi các máy chưa nhận DR, BDR theo priority (reset tiến trình các router cùng lúc)
#clear ip ospf process

Check neighbor
#show ip ospf nei
Check database
#show ip ospf database
Check priority của interface
#show ip ospf interface g0/0

– R1:
(config)#interface loopback 0
(config-if)#ip address 1.1.1.1 255.255.255.255
(config-if)#interface g0/0
(config-if)#no shut
(config-if)#ip address 192.168.16.1 255.255.255.0
(config-if)#interface g0/1
(config-if)#no shut
(config-if)#ip address 192.168.12.1 255.255.255.0
(config)#router ospf 1
(config-router)#network 1.1.1.1 0.0.0.0 area 0
(config-router)#network 192.168.12.1 0.0.0.255 area 0
(config-router)#network 192.168.16.1 0.0.0.255 area 1

– R6: Các mạng trong OSPF sẽ thông qua R6 để đi ra ngoài (R8)
(config)#interface loopback 0
(config-if)#ip address 6.6.6.6 255.255.255.255
(config-if)#interface g0/0
(config-if)#no shut
(config-if)#ip address 192.168.68.6 255.255.255.0
(config-if)#interface g0/1
(config-if)#no shut
(config-if)#ip address 192.168.16.6 255.255.255.0
(config)#router ospf 1
(config-router)#network 6.6.6.6 0.0.0.0 area 1
(config-router)#network 192.168.16.1 0.0.0.255 area 1
(config-router)#default-information originate

(config)#ip route 0.0.0.0 0.0.0.0 192.168.68.8

– R8:
(config)#interface loopback 0
(config-if)#ip address 8.8.8.8 255.255.255.255
(config-if)#interface g0/0
(config-if)#no shut
(config-if)#ip address 192.168.68.8 255.255.255.0

(config)#ip route 0.0.0.0 0.0.0.0 192.168.68.6

Check ping từ 8.8.8.8 tới 5.5.5.5

Leave a Reply

Your email address will not be published. Required fields are marked *